แหล่งรวมความรู้เกี่ยวกับระบบโทรศัพท์ Asterisk, Trixbox , VoIP สำหรับคนไทย
:: เพื่อแลกเปลี่ยนความรู้, ถาม-ตอบปัญหาคาใจ, แนะนำ, ประกาศ, หรือทุกสิ่งตามต้องการ ::
 
Home  กลับหน้าหลัก  สมัครสมาชิก  ตั้งคำถามใหม่  แก้ไขข้อมูลสมาชิก  ดูสมาชิกทั้งหมด  ลืมรหัสผ่าน

ขอเชิญร่วมตอบคำถามครับ



  เล่าเรื่องติดตั้ง Asterisk ให้ฟังครับ...
   foxdevil
 Posted : 2008-05-29 18:29:59

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
หลังจากที่ไปอบรมกับอาจารย์แล้วมั่นใจมากว่าระบบที่จะทำสำเร็จแน่นอน พอมาถึงที่บริษัทฯ (วันจันทร์) ก็รีบติดตั้งระบบเลย กะว่าจะโชว์ให้เจ้านายดูเช้านั้นเลย เพราะเท่าที่ลองทำตอนที่อบรมมันง่ายมาก ๆ ไม่ถึงชั่วโมงก็เรียบร้อยแล้ว

... แต่ช้าก่อนครับ... หนทางไม่ได้โรยด้วยกลีบกุหลาบ...
FreeBSD 6.2 ที่ทีมงานทำให้ใหม่ก็ยังใช้ไม่ได้ครับ อาการเดียวกันกันเลย ค้างเติ่งเหมือนเดิม (เหมือนตอนที่อบรมเลย เสียดายจด error ไว้ไหนไม่รู้ไม่งั้นจะได้โพสต์ถามเพื่อแก้ไขปัญหา)

ลองเอาแผ่นที่มาพร้อมกับหนังสือเล่มแดง (หรือเขียวก็ไม่รู้เพราะซื้อมาพร้อมกัน) ก็เจอปัญหาติดตั้งไม่ได้เหมือนเดิม

เฮ้อ! ชักจะหงุดหงิดเสียแล้ว แต่ก็คิดได้ว่ามีแผ่น Ubuntu Server 7.10 อยู่เลยงัดออกมาใช้ติดตั้งตามที่อาจารย์บอกในหนังสือเล่มขาว

ติดตั้ง Asterisk ผ่านไปด้วยดี โทรผ่าน ATA, Soft phone ได้หมด แต่ปัญหาอยู่ที่การ์ด X100P ไม่ทำงานซะงั้น ก่อนหน้านั้นก็โหลดไดร์เวอร์ zaptel ตามหนังสือบอกไว้แล้ว แต่ก็ไม่ผ่าน

มองเห็นการ์ดแต่โทรเข้าไม่ตอบรับ เช็คที่ extensions.conf แล้วก็ไม่มีอะไรผิด เพราะแอบ copy ตัวอย่างจากตอนอบรมมาด้วย

เวลาเริ่มคืบคลานเข้าไปบ่ายกว่า ๆ เจ้านายก็เดินวนเวียนรอดูผลงาน ที่ยังไม่สำเร็จทั้งหมด เราเริ่มออกอาการ เลยหยุดพัก เข้าเน็ตค้นหาไปเรื่อย ๆ ไปเจอเว็บอยู่เว็บหนึ่ง เกี่ยวกับการติดตั้ง Asterisk บน Ubuntu เลยทำตาม (ทำตามเลยครับ ไม่อ่านด้วย เพราะใจร้อนรน คิดว่าถ้าผ่านก็ผ่านไม่ผ่านก็ลงเซิร์ฟเวอร์ใหม่) ปรากฎว่าผ่านฉลุย โทรติดเลยครับ

ที่เว็บนี้ (https://wiki.ubuntu.com/AsteriskOnUbuntu) เขาเขียนไว้ตั้งแต่เริ่มติดตั้ง Server แล้วผมก็รันตามไปเจอคำสั่ง อัพเกรด Ubuntu เข้าให้รอตั้งเกือบสองชั่วโมง เฮ้อ! จริง ๆ ไม่อัพเกรดก็ได้ครับ ผ่านไปเลยข้ามไปตอนติดตั้ง zaptel เลยก็ได้

หลังจากที่ได้เรียบร้อยแล้วก็ชักมันครับ... กำหนดอะไรต่อมิอะไรเสียยกใหญ่ และใจตอนนี้คิดถึงระบบงานใหญ่แล้วครับ (เกินตัวไปสักนิด ) และก่อนกลับบ้านเลยดาวน์โหลดไฟล์ trixbox 2.6 ce เพื่อติดตั้งระบบแทน เพราะอยากได้ GUI เจ้านายเข้าอยากให้เป็นอย่างนั้นครับ

รุ่งขึ้นหลังจากได้แผ่น Trixbox แล้วก็ลงมือติดตั้ง ดูเหมือนทุกสิ่งทุกอย่างจะง่ายครับ แต่มันมีอุปสรรคอีกแล้วครับท่าน

หลังจากกำหนดอะไรเรียบร้อยแล้วก็ต้องลงมือศึกษาว่ามีอะไรบ้าง เสียเวลาเกือบวัน และเจอปัญหาใหญ่คือ เมื่อสั่ง reboot เซิร์ฟเวอร์แล้วเจอข้อความ Kernel panic - not syncing : fatal exeption และอะไรอีกเยอะแยะ แล้วไม่ทำงานต่อค้างหน้าตาเฉย ต้องไปปิดสวิทซ์แล้วเปิดใหม่

ก็ต้องค้นหาจาก google อีกตามเคย กว่าจะเจอในเว็บhttp://www.pclinuxclub.com/node/234บอกวิธีแก้ไว้ลองทำตามก็ใช้ได้ไม่มีปัญหา แต่ตอนนี้ปัญหาคือไม่รู้จะให้ zaptel ตอบรับทำอย่างไรดีหว่า...

ตามที่เรียนมาก็กำหนดไว้ที่ default ของ extensions.conf เลยแต่นี่ก็กำหนดแล้วก็ไม่ทำงานเลยหยุดไว้แค่นี้ก่อน และก็กลับบ้านไปนอนแบบค้างคาใจ

เมื่อวานนี้ (28) ก็กลับมาแก้ไขปัญหาต่อ (ช่วงนี้งานการอย่างอื่นไม่สนละ เอา Asterisk อย่างเดียวครับ) ค้นหาต่อไป อ่านต่อไปยิ่งงง เพราะคู่มือของ Trixbox ก็อ้างแต่ศัพท์ตัวย่อ ซึ่งผมใจร้อนไม่อยากหา ก็ไม่รู้จะทำอย่างไรเลยโทรหาน้องที่เคยไปอบรมด้วยกันซึ่งเขาถนัด Trixbox (น้องต้า) ก็ถึงบางอ้อต้องกำหนด zaptel ในส่วนของ Extension เฮ้อ! พอกำหนดก็เรียบร้อยครับ ใช้ได้เลย กำหนดอะไรก็ได้ เสียงตอบรับ เสียงเพลงรอสายง่ายจริง ๆ

แต่... อีกแล้วครับท่าน กำลังจะมีความสุขกับการใช้งาน Trixbox ประกฎว่าลองโทรออกจากเครื่องผ่าน ATA กลับไม่ได้ซะงั้น

ยกหู กดปุ่ม มีเสียง ตู๊ด ๆ ๆ ๆ ๆ อย่างเดียว ไม่มีสัญญานอะไรเลย ทีนี้จะกลับเข้าไปดูไฟล์ conf... โอ้! แม่เจ้า มันช่างวุ่นวายเสียกะไรนี่ โยงไฟล์ซับซ้อน context โยงไปโยงมา เฮ้อ! เลยลองลงโปรแกรมใหม่หมดทั้งเซิร์ฟเวอร์ก็ใช้ได้พักเดียว พอกำหนดระบบ IVR เท่านั้นแหละ รวนอีก ค้นหาอยู่จนถึงเย็น จะโทรไปหาน้องต้าก็เกรงใจ เลยตัดสินใจยกเลิก

หันกลับไปดาวน์โหลด FreeBSD 6.2 จากเว็บ FreeBSD อีกครั้งเพราะเคยโหลดได้แล้วติดตั้งได้ แต่ตอนนหันกลับไปใช้ Ubuntu ตามเดิมดีกว่า เพราะรู้แล้วว่าตนเองถนัดแบบลูกทุ่ง ๆ หน้าจอสวยงามแบบชาวกรุงเอาไว้ก่อนเถอะตอนนี้ไม่ถนัดจริง ๆ ขอเปิบข้าวกับน้ำพริกปลาทูแทนสลัดและพิซซ่าไปก่อน ไว้พรุ่งนี้โหลด FreeeBSD เสร็จแล้วลองลงดูจะเทียบกับ Ubuntu ว่าเป็นอย่างไร

ที่แน่ ๆ การเข้าไปหาเซิร์ฟเวอร์ด้วย ssh ของ Ubuntu เร็วกว่า CentOS ของ Trixbox ครับ...

ใครที่หลงอ่านมานานก็ถือว่ามาฟังประสบการณ์เปิ่นของผมนะครับ ใครมีอะไรจะแนะนำก็ชี้แนะได้ และขออนุญาตอาจารย์ไว้ ณ ที่นี้ที่ถือวิสาสะเข้ามาเล่าเรื่องราวที่หาสาระไม่ค่อยได้ของผมบนเว็บแห่งนี้...



 
  IP : (203.154.212.58)
ชื่อสมาชิก foxdevil Mail to foxdevil
แสดงความคิดเห็น

   foxdevil
 Posted : 2008-05-30 08:38:46   IP : (203.154.212.58)

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
ลองนำแผ่น FreeBSD 6.2 ที่ดาวน์โหลดจาก FreeBSD ไปติดตั้งผ่าน VMWare ก็ไม่ได้ครับ อาการเดียวกันเลย ค้างที่หน้าจอ

Adding packages/All/linux_base-fc-4_9.tbz from acd0

ค้างอย่างนี้นานมาก ตอนแรกแผ่น cd กับไฟฮาร์ดดิสก์ติดกระพริบ นาน ๆ เข้าก็ดับไปเสียทั้งสอง

ในที่สุดก็ต้องปิด VMWare แล้วเริ่มใหม่ เข้า freebsd ได้แต่มีไฟล์และคำสั่งไม่ครบ

ใครเคยเจอปัญหานี้บ้างครับ

ผมกะว่าจะดาวน์โหลดเวอร์ชัน 7.0 มาลองใช้อีกไม่รู้ว่าจะเจอเหมือนกันเหรือเปล่า หรือว่าดวงเราจะไม่สมพงษ์กัน

หรือว่าผมจะต้องใช้ Ubuntu ไปเสียแล้ว ไหน ๆ ก็ใช้ Desktop เป็น Utuntu อยู่แล้วก็ไม่ค่อยกลัวสักเท่าใดนัก...

 
 Comment : 1
ชื่อสมาชิก foxdevil Mail to foxdevil
กลับขึ้นด้านบน

   nari
 Posted : 2008-05-30 10:31:27   IP : (124.121.4.133)

 หน้าใหม่ไร้วรยุทธ์
 

 Sex :
 Post : 16
 สมาชิกลำดับที่ : 2543
ไม่ทราบว่าพี่ติดตั้ง Ubuntu Server 7.10 ทางไหนครับ
ผ่านโปรแกรม VM หรือว่าติดตั้งกับ Patition อื่นเลยครับ
เพราะผมมีปัญหาว่า Registry IP-Phone กับ Server ไม่ได้อ่ะครับ
เพราะผมติดตั้ง Servre ผ่าน VM นะครับ

 
 Comment : 2
ชื่อสมาชิก nari Mail to nari
กลับขึ้นด้านบน

   foxdevil
 Posted : 2008-05-30 11:11:35   IP : (203.154.212.58)

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
ของ Ubuntu ติดตั้งโดยตรงกับเครื่อง PC และใช้ฮาร์ดดิสก์หมดเลยครับ ส่วน FreeBSD ทั้งติดตั้งผ่าน VMWare และติดตั้งตรงก็ไม่ผ่าน ผมเลยงงครับ ไม่รู้ว่าเป็นที่เครื่องหรือเปล่า ผมยังไม่ได้ลอง FreeBSD 6.2 กับเครื่องที่เป็น Server จริงเลย ลองแต่ PC ธรรมดา

แต่คงจะใช้ Ubuntu แล้วล่ะครับ เพราะปกติผมใช้ Desktop อยู่ และตอนนี้ Asterisk ใช้ได้ปกติแล้วครับ กำลังขยายไปทำเรื่องของ Agent และ Call Queue ครับ อ่านจากเว็บต่างประเทศก็มึน ๆ เหมือนกัน

 
 Comment : 3
ชื่อสมาชิก foxdevil Mail to foxdevil
กลับขึ้นด้านบน

   nari
 Posted : 2008-05-30 14:12:39   IP : (124.121.4.133)

 หน้าใหม่ไร้วรยุทธ์
 

 Sex :
 Post : 16
 สมาชิกลำดับที่ : 2543
ผมลงโปรแกรม VM เพื่อจำลองระบบ Linux Server นะครับ
ขั้นตอนการลงไม่มีปัญหา แล้วที่บริษัทผมมี IP-Phone ของ Grandstream GXV-3000
ซึ่งผมก็พยายามจะ Registry เครื่องกับ Linux แต่ก็ไม่ Ok ซักทีครับ
ผมสร้างไฟล์ sip.conf กับไฟล์ extensions.conf แล้วดังนี้ครับ

extensions.conf

exten => 65001,1,Dial(SIP/65001)
exten => 65002,1,Dial(SIP/65002)

แล้วไฟล์ sip.conf เป็นดังนี้ครับ

context=default
bindport=5060
bindaddr=0.0.0.0

[65001]
user=65001
secret=1234
host=dynamic
type=friend

[65002]
user=65002
secret=1234
host=dynamic
type=friend

พอผมเช็คใน Asterisk ด้วยคำสั่ง sip show registry มันก็ไม่ขึ้นอะไรเลยครับ

ช่วยผมด้วยนะครับ ขอบคุงครับ


 
 Comment : 4
ชื่อสมาชิก nari Mail to nari
กลับขึ้นด้านบน

   foxdevil
 Posted : 2008-05-30 20:42:03   IP : (203.154.212.58)

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
ผมลองคำสั่ง sip show registry ก็ไม่ขึ้นอะไรนะครับ ไม่รู้ว่าของผมผิดหรือเปล่า แต่โทรระหว่างเครื่องได้ ผมใช้ ATA ของ PAP2T นะครับ

 
 Comment : 5
ชื่อสมาชิก foxdevil Mail to foxdevil
กลับขึ้นด้านบน

   9jumper
 Posted : 2008-05-30 21:44:12   IP : (124.120.2.170)

 หน้าใหม่ไร้วรยุทธ์
 

 Sex :
 Post : 13
 สมาชิกลำดับที่ : 2586
ตั้งแต่ไปอบรมมา ยังไม่ได้ทดลองเลยครับ ไม่ว่างเลย หวังว่าคงไม่เจอปัญหาเยอะขนาดนี้ สู้ต่อไปครับ

 

ก้าวกระโดดสู่จุดที่ยิ่งใหญ่
 Comment : 6
ชื่อสมาชิก 9jumper Mail to 9jumper เบอร์ msn nai_pon39@hotmail.com
กลับขึ้นด้านบน

   foxdevil
 Posted : 2008-05-31 12:20:20   IP : (203.154.212.58)

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
วันนี้ก็เข้าวันที่ 6 แล้วครับ หลังจากที่ติดขัดหลายประการ
ถ้านับรวมจริง ๆ แล้วเอาเฉพาะวันที่ติดตั้งระบบครั้งล่าสุด (ที่ลงเซิร์ฟเวอร์ใหม่ ) ก็เป็นวันที่ 3 ที่ได้ลองผิดลองถูก

เมื่อวาน (31) ได้ลองระบบคิวแต่ก็ไม่ประทับใจ เพราะได้อ่านจาก voip-info.org ก็มาลองทำดูครั้งแรกใช้คำสั่ง AgentLogin() ปรากฎว่าเมื่อผู้ใช้งาน Login เข้าไปก็ได้ยินเสียงเพลงรอสายค้างไว้เลย ถ้าวางสายก็ตัดออกจากระบบไป และถ้ามีสายเข้าก็จะได้ยินเสียง บิ๊บ แล้วก็คุยได้เลย

ดูแล้วไม่ประทับใจครับ Agent คงจะเบือเพลงไปแน่ ๆ ถ้าใช้ระบบนี้ เลยหาใหม่ ไปเจอคำสั่ง AgentCallBackLogin() ซึ่งเป็นคำสั่งสำหรับโทรกลับถ้าหากมีสายเข้า

ได้ผลครับหลังจากที่ Agent Login เข้าไปแล้ววางสายได้เลย หลังจากมีคนโทรเข้าก็จะมีเสียงที่เครื่องโทรศัพท์แต่คราวนี้มีปัญหานิดหน่อย เสียงดังไปทุกเครื่องร้องระงมเลย ต้องไปเปลี่ยนที่ stategy ใหม่ให้เป็นการจัดระบบคิวเครื่องที่ว่าง ก็ได้ผลดี

แต่ปัญหากลับมีเสียงไปดังที่เครื่องอีกเครื่องหนึ่งที่ยังไม่ได้ Login และไม่ได้กำหนดให้เป็น Agent เสียด้วย

หายังไงก็ไม่เจอสาเหตุ ลองโทรเข้ามาจากสายนอกผ่าน Zaptel ก็เหมือนเดิม เสียงก็ไปดังเครื่องที่ไม่ได้กำหนดให้เป็น Agent ตลอด จนออกอาการหงุดหงิดและท้อ เหมือนกัน คิดไปคิดมาเกือบจะลงใหม่อีกรอบ แต่ยังดีที่ได้ข้อคิดแบบอาจารย์กิตติพงษ์บอก คือ การลงเซิร์ฟเวอร์ใหม่เป็นหนทางสุดท้ายและมันง่ายเกินไป เราต้องหาให้เจอ

สรุปแล้ว 3 ทุ่มเศษ ยังหาไม่ได้เลยกลับบ้านไปนอนก่อนรุ่งขึ้นค่อยว่ากันใหม่

เช้านี้มาถึงที่ทำงานก็เคลียร์จิตใจให้แจ่มใส แล้วลุยต่อไปอีกพักใหญ่ก็ยังไม่สำเร็จ

สุดท้ายไล่ตัด comment ของไฟล์ sip.conf, agents.conf, queues.conf และ extensions.conf เพื่อให้เหลือที่ใช้งานจริง ๆ

โอ้! พระเจ้าจอร์จ โลกมันสว่างขึ้นทันที แต่ละไฟล์เหลือไม่กี่บรรทัด อ่านง่ายดีครับ

แต่ปัญหาก็ยังไม่พบ แต่พอจับจุดได้ว่าเสียงที่ดังอีกเครื่องหนึ่ง (ไม่ได้เป็น Agent) มันอยู่ใน exten,s,... สำหรับกำหนดในระบบ IVR นั่นคืออยู่ในระบบ กด 1 กด 2 และ 0

พักจากการหาใน config เพราะคิดว่ามันต้องถูกต้อง เลยกลับไปอ่านใน web ต่อว่าระบบ Login เป็นยังไง ก็ไปสะดุดคำว่า extension ที่เป็น Options ของการล็อคอินแล้วให้โทรกลับ

เลยเข้าไปที่ asterisk -r แล้วใช้คำสั่ง agent show
BingGo! เพราะขณะที่ Agent ล็อคอินดันไปกด Extension ที่จะให้โทรกลับเป็นเบอร์ 1 และ 2 ทำให้เวลามีสัญญานเรียกเข้าก็ไปดังที่ Exten 1, 2

พอให้ Agent Login ใหม่แล้วให้กำหนด Exten ให้ถูกต้องก็ใช้ได้ครับ

Asterisk... จงเจริญ!

 
 Comment : 7
ชื่อสมาชิก foxdevil Mail to foxdevil
กลับขึ้นด้านบน

   foxdevil
 Posted : 2008-06-01 09:31:31   IP : (203.154.212.58)

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
เรื่องมันเศร้า... ด้วยใจที่อยากจะลง FreeBSD เพราะเจอปัญหาติดตั้ง MySQL Add-ons ใน Ubuntu ไม่ผ่าน ติดยังไง ๆ ก็ error หาในเว็บก็ไม่มีใครพูดถึง เลยอยากจะลงบน FreeBSD บ้าง

แต่ชะตากรรมทั้งโหลดใหม่ แผ่นเก่าที่ติดมากับหนังสือ แผ่นที่เคยลงไว้ ก็ลงไม่ได้สักที ติด error เดิม ๆ แล้วก็ค้างทั้งคืน (นี่ขนาดทิ้งไว้ทั้งคืน) ไม่รู้ว่าติดขัดยังไง ถามไปกี่เว็บ ๆ ก็เงียบหาย ไม่รู้ว่าชะตากรรมผมต้องตาต้องใจกับ Ubuntu ขนาดนี้เชียวหรือ

วันนี้ก็เลยกลับมานั่ง config ใหม่ ถือซะว่าเป็นการฝึกติดตั้ง Asterisk ก็แล้วกัน ตอนนี้ก็ ok หมดแล้วล่ะ ทั้งติดตั้งและ config ไม่ต้องดูหนังสือละ มันอยู่ในสมองเสียแล้ว แต่ตอนนี้ปัญหาคือทำอย่างไรถึงจะติดตั้ง MySQL ADD-ONs ได้เสียทีก็ไม่รู้...


 
 Comment : 8
ชื่อสมาชิก foxdevil Mail to foxdevil
กลับขึ้นด้านบน

   foxdevil
 Posted : 2008-06-02 18:11:49   IP : (203.154.212.58)

  ศิษย์น้อยฝึกวิชา
 

 Sex :
 Post : 268
 สมาชิกลำดับที่ : 2519
ย่างเข้าวันที่ 8 ที่นั่งขลุกกับ Asterisk ตอนนี้ไม่ได้วุ่นวายกับการ config asterisk แต่กำลังวุ่นกับการลง MySQL Addons สาเหตุที่วุ่นวาย มากมายก่ายกองก็เพราะความไม่เข้าใจนั่นแหละ

หลังจากที่มืดแปดด้านตอนนี้ก็ค่อยเห็นแสงสว่างขึ้นมาบ้างเมื่อลองคอมไพล์ ลองหลาย ๆ อย่าง ลง Server ใหม่อีกสองสามครั้ง

ก็นับว่าคุ้มครับจากความรู้ที่แทบจะเป็นศูนย์ (ลำพังความรู้แค่ติดตั้งเซิร์ฟเวอร์เพื่อใช้งาน MySQL แค่นั้นเอง)

ตอนนี้ต้องลองทุกวิธี จนในที่สุดก็รู้ว่าสาเหตุที่ make install addons ไม่ผ่านเพราะขาดไฟล์ asterisk.h ไปไฟล์เดียวเท่านั้นเอง แต่พอคอมไพล์แล้ว make install ใหม่คราวนี้กลับรันไม่ได้เพราะไปทับของเดิมแล้ว error หาไฟล์ /var/run/asterisk.ctl หาวิธีแก้ยังไงก็ไม่หาย

ในที่สุดก็เลยต้องลงใหม่ ใจจริงอยากจะหาวิธีแก้ไขแต่ตอนนี้จุดมุ่งหมายของงานเปลี่ยนไป ต้องเร่งให้ทันภายในอาทิตย์นี้ และต้องสรุปเลยต้องใช้วิธีลัด ลงใหม่อย่างเดียวครับ

ไว้จะมาเล่าให้ฟังใหม่ว่าผลเป็นอย่างไร

 
 Comment : 9
ชื่อสมาชิก foxdevil Mail to foxdevil
กลับขึ้นด้านบน

 kittipong
 Posted : 2008-06-02 22:49:31   IP : (118.172.136.212)
เพิ่งได้เข้ามาอ่าน ไปอยู่ กทม. สองสามวัน


- แผ่น 6.2 อาจจะมีปัญหานะครับ ไม่โทรบอกอาจารย์ล่ะครับจะได้ส่งแผ่นตัวใหม่ไปให้นะ
- ตัว add-ons ไม่น่ามีปัญหานะ make install ก็น่าจะผ่านแล้ว
- หากการ config ระบบ ใจร้อน ก็จะมีปัญหานะครับ ค่อย ๆ ทำ



ส่วนคุณ nari
แน่ใจไม่ว่าเขียนคำสั่งถูก (หาคำตอบดูนะ)
[65001]
user=65001
secret=1234
host=dynamic
type=friend



 
 Comment : 10
กลับขึ้นด้านบน

1 2


 แสดงความเห็นต่อคำถามนี้
ชื่อ/Username
รหัสผ่าน
( เฉพาะสมาชิก )
อีเมลล์
( ถ้าเป็นสมาชิกไม่ต้องใส่ )
รูปแบบพิเศษ   ย่อหน้า ตัวหนา ตัวยก ตัวห้อย ตัวหนังสือเรืองแสง ตัวหนังสือมีเงา ตัวเอียง เส้นใต้ สีแดง สีเขียว สีน้ำเงิน สีส้ม สีชมพู สีเทา
Emotions  
แทรกภาพ  
ขนาดภาพ ห้ามเกิน 50 kb  และ ไฟล์ Flash ขนาดห้ามเกิน 500 kb
แสดงความเห็น

ความปลอดภัย กรุณากรอกข้อความที่ท่านเห็นด้านล่าง
   
   
   
[ สมัครสมาชิก | ปิดหน้าต่างนี้ ]


ข้อความที่ท่านได้อ่าน เกิดจากการเขียนโดยสาธารณชน และส่งขึ้นมาแบบอัตโนมัติ เจ้าของเว็บบอร์ดไม่รับผิดชอบต่อข้อความใดๆทั้งสิ้น เพราะไม่สามารถ
ระบุได้ว่าเป็นความจริงหรือชื่อผู้เขียนที่ได้เห็นคือชื่อจริง ผู้อ่านจึงควรใช้วิจารณญาณในการกลั่นกรอง และถ้าท่านพบเห็นข้อความใด ที่ขัดต่อกฎหมายและ
ศีลธรรม หรือเป็นการกลั่นแกล้งเพื่อให้เกิดความเสียหาย ต่อบุคคล หรือหน่วยงานใด กรุณาส่ง email มาที่ admin@thaibsd.com เพื่อให้ผู้ควบคุม
ระบบทราบและทำการลบข้อความนั้น ออกจากระบบต่อไป


 © Copyright 2001 thaibsd.com All Right Reserved. Contact >> admin@thaibsd.com